Vanilla Forum v2.6 mit Sicherheitsfixes erschienen

Vanilla Forum v2.6 mit Sicherheitsfixes erschienen

Hallo Blogleser und Vanilla-Forum-Admin! Es gibt wieder sehr erfreuliche Vanilla-Neuigkeiten, weil eine neue Sicherheitsversion v2.6 nach draussen befördert wurde. Das jeweilige Update konnte ich soeben erfolgreich installieren.

Ich habe auch noch mein altes Vanilla-Forum neu aufgesetzt unter https://vanilla.apps-tools-cms.de. Und unter https://open.vanillaforums.com/discussion/36260/vanilla-2-6-is-here-includes-security-fixes ist die öffentliche Update-Bekanntmachung, damit du dir die Fehlerbehebungen sowie Sicherheitsfixes genauer ansehen kannst.

Vanilla Forum funktioniert auch schon unter PHP 7.2. Dennoch manche Apps und meine WordPress-Installationen wollen noch nicht mit PHP 7.2.6 laufen, daher habe ich noch PHP 7.1.18 überall. Das reicht locker aus und ich gehe mit der Technik der heutigen Zeit mit.

Es ist genial, wie viele Behebungen die Entwickler dieses Mal umsetzten und für paar Monate vergass ich, dass ich auch noch ein solches kleines und sehr junges Vanilla-Forum besitze. Doch heute in den Backups wieder gesehen und gleich aufgesetzt. Ich hoffe nur, dass die Sicherheit meines Rootservers immer gegeben sein wird. Alles CMS/Forum-Apps-Updates gehören dringend installiert. Das sollte so passend sein.

Nun noch wie du Vanilla updaten kannst.

Vanilla Forum auf v2.6 aktualisieren – wie geht das?

Sichere bitte deine MySQL-Datenbank und lade dir die neue Version von den Vanilla Seiten herunter. Danach lädst du alles wieder zum Server bzw. FTP-Account hoch und navigierst im Browser zu:

meinedomain.de/utility/update

Das wäre auch schon alles und wenn dann “Success” steht, dann war das Update mit Erfolg vollbracht. Ach ja, noch etwas! Lösche bitte nach dem Upgrade den Inhalt des Verzeichnisses /cache, damit die Änderungen live sind. Auch solltest du die Plugins wie “Tagging” und “HTMLawed” ebenfalls löschen, weil sie ab sofort im Kern dieser Software enthalten sind. Darauf kannst du noch etwas achten.

Ich habe heute mehrmals das Dashboard meiner Vanilla-Installation aufgerufen und es schien alles in Ordnung zu sein. Dann habe ich einen neuen Adsense-Code entsprechend der neuen Domain hinzugefügt, was du mit dem Plugin Pockets machen kannst. Das Pockets-Plugins ist genial und genau das Richtige, um Werbung innerhalb des Forums zu platzieren. Schaue es dir an und Pockets scheint mir mit Vanilla 2.6 kompatibel zu sein. Ich habe ja alle Plugins im November 2017 installiert. Denke mal, dass es schon neue Plugin-Versionen gibt und auch bei Zeiten muss ich sie installieren.

#Vanilla #Forum #Sicherheitsupdate v2.6 erschienen. Es läuft schon unter PHP 7.2. Klick um zu Tweeten

Sehr wichtig wäre es, darauf zu achten, dass auch alle Plugins uptodate sind, denn man kennt das, dass es Sicherheitslecks sind oder zumindest wäre so etwas angreifbar.

Demnach kann ich das heutige Vanilla-Update weiterempfehlen und werde es über meine Foren bekannt machen.

Falls du Fragen dazu hast und ich mehr als du weiss, dann helfe ich dir gerne, das Update zu machen.

by Alexander Liebrecht

Konstruktives Feedback ist gerne gesehen!

Leave a reply

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.